Test important avant la migration de bases de données

FlexNet Manager Suite version 2018 R2
Conseil : Si vous utilisez une implémentation cloud de FlexNet Manager Suite, vous pouvez passer cette rubrique, car cette tâche est déjà gérée pour vous.
Si vous mettez à niveau votre implémentation sur site depuis une publication antérieure de FlexNet Manager Suite vers 2019 R1.5, il est important de noter que toutes les données actuellement présentes dans vos bases de données FlexNet, et qui sont incompatibles avec les contraintes de bases de données sous-jacentes, entraîneront l’échec de la migration de votre base de données, ainsi qu’un arrêt de votre mise à niveau. Des cas d’insertion de données clients non compatibles avec les contraintes ont été identifiés après des mises à niveau antérieures. Ces insertions entraînaient des erreurs de conformité dans les opérations sous-jacentes. C’est pourquoi cette rigueur accrue est désormais appliquée. Toutes les bases de données suivantes sont dorénavant soumises à ce contrôle des contraintes, ce qui réactive également toutes les contraintes désactivées :
  • La base de données de conformité (nom par défaut FNMSCompliance)
  • La base de données d’inventaire (nom par défaut FNMSInventory)
  • La base de données de l’entrepôt de données (nom par défaut FNMSDataWarehouse).
Afin d’éviter de tels échecs durant la migration, il est important d’exécuter en premier lieu un nouveau script de base de données sur chacune d’elles, l’une après l’autre. Le script identifie les contraintes qui doivent être honorées, et produit une instruction SQL pour chaque cas. Vous copiez ensuite les instructions SQL et exécutez ces instructions personnalisées sur vos bases de données. S’il existe des incompatibilités avec les contraintes de base de données, une alerte similaire à celle-ci est produite :
Des données existent dans la dbo.nomTable pouvant entraîner la rupture du lien de foreign key FK_nom
En souhaitant que de tels cas ne soient pas présents dans vos bases de données, vous pouvez ensuite poursuivre avec la mise à niveau de la base de données. Cependant, si vous voyez de telles alertes dans ce test, pour l'une des bases de données citées ci-dessus, les erreurs doivent être corrigées avant de pouvoir procéder à la mise à niveau. Vos administrateurs de base de données peuvent parcourir le PDF Schema Reference pour de plus amples informations sur les contraintes; mais, de manière générale, il est recommandé de créer un ticket de support afin que les experts de Flexera vous aident à nettoyer les données problématiques.
Le script de base de données nécessaire aux vérifications avancées de vos bases de données actuelles est disponible :
  • Dans le guide de mise à niveau (Upgrade Guide, en anglais uniquement), disponible via le portail communauté de clients Flexera (et il sera également disponible via la page d’accueil de l’aide en ligne après votre mise à niveau)
  • Dans l’article de la base de connaissances 000027104 Database Validation Before Upgrading to FlexNet Manager Suite2019 R1.5, également accessible via le portail communauté de clients Flexera.