Inventory beacon changes and fixes

FlexNet Manager Suite version 2019 R2

Support for Linux KVM virtualization inventory

If you wish to use zero footprint inventory collection (remote inventory by an inventory beacon), FlexNet Beacon 14.0.0 must be installed – check the splash screen on start-up.

Fixes for FlexNet Beacon

  • This version reduces FlexNet Beacon engine’s DNS lookups, avoiding situations where too many DNS reads occur. As well, it limits DNS reads so that there are no reads outside a particular FlexNet Beacon's assigned subnet.
  • This version corrects a problem in environments that use a parent/child inventory beacon hierarchy, where child inventory beacons were not properly downloading adoption and upgrade packages from their parent inventory beacon. The fix requires that FlexNet Beacon version 14.0.x or later is installed at all points in the inventory beacon chain leading to child inventory beacons. However, inventory beacons that have no descendents do not need to be upgraded.

All changes for FlexNet Beacon are tracked in the Beacon Change Log, available from https://helpnet.flexerasoftware.com/fnms/EN/BeaconChg/index.html.