FlexNet inventory agent changes and fixes

FlexNet Manager Suite version 2019 R2
This release of FlexNet Manager Suite 2019 R2.1 updates the FlexNet inventory agent to 14.0.0. The following functionality depends on the use of version 14.0.0 (or later) of FlexNet inventory agent:
  • Gathering inventory when installed on an Apple inventory device that is running macOS 10.15 or later (see Support for macOS 10.15 inventory and FlexNet inventory agent (Mac) now supports 64-bit only versions of macOS)
    Important: If previous releases of FlexNet inventory agent are already installed on Apple inventory devices currently running earlier versions of macOS, these installations need to be upgraded to FlexNet inventory agent version 14.0.0 or later before the OS is upgraded to macOS 10.15. If the OS is upgraded without first upgrading the installed FlexNet inventory agents, the existing FlexNet inventory agent will no longer be able to run on the upgraded inventory device. As a result, in this scenario it will be impossible for device policy to upgrade the FlexNet inventory agent. Recovering from such a case will require manually upgrading the FlexNet inventory agent to version 14.0.0 or later.
  • Gathering inventory from devices using Linux KVM virtualization (see Support for inventory of Linux KVM virtualization).