Compatibility with Other Products

This section describes the compatibility of FlexNet Manager Suite 2019 R1.4 with other products at the time of release.

Integration with Other Products

FlexNet Manager Suite integrates with the following products and components. Support for third-party products is based on the original software vendors publicly stated support dates. If an environment is no longer supported by the original software producer, Flexera will provide "as is" support, meaning troubleshooting issues, without committing to any defect fixes or enhancements. This table details the currently supported versions:

Product/Component Version that can be imported from

App Portal

2013 R2–2019 R1

BDNA Normalize (Data Platform)

5

BMC BladeLogic Client Automation (Marimba)

8.2

BMC Discovery (ADDM)

9.0, 10.0–10.2, 11.0–11.3

Citrix XenApp EdgeSight

5.4, 7.6, 7.14–7.16 (requires a Platinum license), 7.17–7 1903

Citrix XenApp Server

6.0, 6.5, 7.5-7.9, 7.11–7 1903

Citrix XenDesktop

5.6, 6.0, 6.5, 7.5-7.9, 7.11–7 1903

FlexNet Manager for Engineering Applications

15.5, 2016 R1-2019 R1

HP Discovery and Dependency Mapping Inventory (DDMI)

9.30

HPE Universal Discovery (HP-UD)

10.10, 10.11, 10.33-11.5

IBM BigFix (previously Tivoli Endpoint Manager) on Microsoft SQL Server

8.2–9.5.13
Tip: Do not confuse the individual IBM BigFix products. IBM BigFix platform (often referred to as simply "BigFix") and IBM BigFix Inventory are quite distinct. You may import inventory from IBM BigFix if this is your only IBM BigFix platform product. However, if you also have IBM BigFix Inventory, you normally need import inventory only from IBM BigFix Inventory (see below).

IBM License Metric Tool (ILMT) or IBM BigFix Inventory on IBM DB2

  • IBM BigFix Inventory was previously known as IBM Software Usage Analysis (SUA), and SUA is supported (on IBM DB2) for versions 9.0, 9.1
  • Rebranded from version 9.2.1, IBM BigFix Inventory on IBM DB2 is supported for versions 9.2.5–9.2.14.

IBM License Metric Tool (ILMT) or IBM BigFix Inventory on Microsoft SQL Server

  • IBM BigFix Inventory on Microsoft SQL Server: 9.2.3–9.5.13
  • ILMT on Microsoft SQL Server: 9.0, 9.1, 9.2.3–9.2.14

IBM Passport Advantage

as of November 2014

Microsoft App-V Integration Server

4.6, 5.0–5.1.85

Microsoft Exchange ActiveSync

2010-2013

Microsoft Hyper-V

Running on:

  • Windows Server 2008 x64
  • Windows Server 2008 x64 Server Core
  • Windows Server 2008 R2 x64
  • Windows Server 2008 R2 x64 Server Core
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows Server 2019.

Microsoft SCCM (previously SMS)

2007, 2012, 2012 R2, 1511–1902

Oracle Database

8i, 9i, 10g, 11g, 11g Release 2, 12c, 18c

Notes:

  • 8i — requires a direct inventory beacon connection

  • 9i — requires a named account on Windows or a direct inventory beacon connection

  • 12c — the Oracle Multitenant option is not supported using a local agent.

Oracle Enterprise Manager

12.1–13.3

Oracle VM Server for x86

3.2–3.4.6

ServiceNow

  • Kingston
  • London
  • Madrid.
Symantec IT Management Suite (Altiris)

6.5, 7.1, 7.5

VMware vSphere/vCenter/ESXi

5.0–6.7

Note: Remote inventory is not possible on the free license versions of ESXi.

Workflow Manager

2014–2016

Note: Further detail is available from the Gathering FlexNet Inventory guide, listed in the opening page of the online help.

Inventory Components

The following table lists the versions of the FlexNet Beacon and FlexNet inventory agent that can be managed by FlexNet Manager Suite 2019 R1.4.

Component Compatible versions

FlexNet inventory agent (Windows)

FlexNet inventory agent (Linux)

FlexNet inventory agent (Solaris)

FlexNet inventory agent (Mac OS X)

FlexNet inventory agent (AIX)

FlexNet inventory agent (HP-UX)

8.5–9.2, 2014–2019 R1.4

Note: Earlier versions are compatible in that they receive default policy and collect inventory on schedule. They cannot support more recent agent functionality, such as:
  • Internet Protocol version 6 (IPv6)

  • Control of usage tracking through UI settings (rather than .ini files and registry controls), from 2014 (R1)

  • Settings targeted by IP addresses, from 2014 (R1)

  • CAL inventory, from 2016 R1.

Citrix XenApp server agent

2014 R3–2019 R1.4

FlexNet Beacon

2017 R2–2019 R1.4
Tip: Older inventory beacons continue to function with this release, but Flexera strongly recommends that you update to at least the range shown.
  • Citrix XenApp inventory requires FlexNet Beacon 2014 R2 or later
  • AWS EC2 connector requires FlexNet Beacon 2018 R2 (13.1.x) or later.