Prerequisite Software

The table below describes the supported operating systems and software prerequisites of FlexNet Manager Suite 2019 R2 at the time of release. Unless otherwise noted, support for a release includes support for all official service packs issued against the same release.
Component Operating System Prerequisite Software

Application Server

  • Windows Server 2008 R2 x64 SP1-SP2
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows Server 2019.
The following three prerequisites apply to each server in a multi-server implementation:
  • Microsoft .NET Framework 4.5–4.7.2 (registration of ASP.NET is documented in Configure .NET and IIS, in either the Installation or Upgrading PDF files)
  • Microsoft Internet Information Services 7.0–10.0
  • Microsoft Message Queuing (MSMQ).
The following additional prerequisites apply only when the batch server components are installed.
Important: There must be one and only one batch server in your environment. The batch server may be installed on its own server; or it may be co-located on either your web application server or your inventory server; or all components may be installed on a single application server. Wherever the batch server is installed, the following additional prerequisites apply.
  • Microsoft Access Database Engine (32-bit)
  • SQL Server features: Client Tools Connectivity, Management Tools.
    Note: Microsoft Windows Server Core editions are not supported.
Database Server (including Cognos Database Server)
  • Windows Server 2008 R2 x64 SP1
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows Server 2019.
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2016 SP1
  • Microsoft SQL Server 2017
  • Microsoft SQL Server Client Tools, of the same version.
Note:
  • Microsoft SQL CLR integration must be enabled.
  • All FlexNet Manager Suite databases, including the Cognos content store database, should be run with compatibility level set to Microsoft SQL Server 2012 (110) when running on SQL Server 2014 or later.
  • For SQL Server 2016, ensure that at least SP1 has been applied, as this update repaired a fatal error.
  • Multi-tenant installations require the Enterprise Edition of SQL Server. Single-tenant installations can use any edition of SQL Server.
  • Flexera Analytics requires that Microsoft SQL Server be configured to have the TCP/IP protocol enabled, and has network permissions to communicate with the database server (this may be prevented by firewall restrictions).
Flexera Analytics / Cognos Server
Note: Flexera Analytics Server is not supported in multi-tenant installations.
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016
  • Windows Server 2019.
.NET Framework 4.5–4.7.2 (registration of ASP.NET is documented in Configure .NET and IIS, in either the Installation or Upgrading PDF files)
Important: When Flexera Analytics is installed on a server other than the database server running the content store database, Microsoft SQL Server Native Client 2012 must be installed on the server hosting Flexera Analytics (this 2012 version of the Native Client interoperates successfully when the remote database is SQL Server 2016 SP1 with the correct compatibility mode set, as noted above).
Admin Module Transport for FlexNet Manager for SAP Applications
  • SAP Basis release from 7.0 to 7.52.
The SAP GUI matching the SAP release must be installed.
Satellite Transport for FlexNet Manager for SAP Applications
  • SAP Basis release from 4.6C to 7.52.
No prerequisites.
Web Browser
  • Microsoft Internet Explorer 10–11
  • Microsoft Edge for Windows 12–18
  • Google Chrome 64–72
  • Mozilla Firefox 57–64
  • Apple Safari 9–12.1.3.

Some Flexera Analytics menu options are not available in the Chrome browser. For further information refer to this IBM Knowledge Center article.

Support for future web browser releases cannot be verified, however there are no anticipated issues for future releases.

Flexera Analytics is not compatible with Microsoft Edge.

A minimum screen resolution of 1024 horizontal pixels is required.

FlexNet inventory agent
  • Windows Server 2003 SP1 and SP2, 2008 R2 x64, 2012, 2012 R2, 2012 R2 SP1, 2016, 2019
  • Windows Server Core 2008, 2008 R2 x64, 2012, 2012 R2
  • Windows Server Standard (previously known as Windows Server Core) 2016, 2019
  • Windows Vista x64, 7 x64, 8 x64, 10 x64
  • Windows Vista, 7, 8, 10.
  • AIX 7.1 LPARs, 7.2
  • Amazon Linux 2
  • CentOS 6–7.5 (x86, 32-bit and 64-bit), 7.6 (x86 64-bit only)
  • Debian Linux 7–10 (x86, 32-bit and 64-bit)
    Note: For Debian Linux 9.4, 9.5 and 10 (both 32-bit and 64-bit), minimal installations of the OS core omit the ifconfig command. This prevents collection of the IP address and MAC address in inventory. The root user can use the following command to restore this functionality:
    apt-get install net-tools  -y
  • Fedora Linux 25-30 (x86, 32-bit and 64-bit); 27-29 (x86 64-bit only)
  • HP-UX 11i v3, vPars/nPars
  • macOS 10.6–10.15
  • OpenSuSE Leap 42.2, 42.3 (x86, 32-bit and 64-bit); 15-15.1 (x86 64-bit only)
  • Oracle Linux 4.5–6.10 (x86, 32-bit and 64-bit); 7.0-8.0 (x86 64-bit only)
  • Red Hat Enterprise Linux 5.0–6.10 (x86, 32-bit and 64-bit); 7.0-8.0 (x86 64-bit only)
  • Red Hat Linux 8–9 (x86 only)
  • Solaris 8–11 (SPARC), Zones for versions 10–11
  • Solaris 9–11 (x86), Zones for versions 10–11
  • SuSE Linux Enterprise Server 11 (x86, 32-bit and 64-bit); 12.3, 12.4, 15-15.1 (x86 64-bit only)
  • Ubuntu 12–17.04 (x86, 32-bit and 64-bit); 17.10-18.10 (x86 64-bit only).
No prerequisites.
FlexNet Beacon
  • Windows Server 2008 R2 x64, 2012, 2012 R2, 2016, 2019
  • Windows 7 x64, 8 x64, 10 x64
  • Window 7, 8, 10.
  • .NET Framework versions 4.5.2–4.7.2.
  • Any supported web browser.
  • For Oracle Database inventory, Oracle OLE DB Provider (32-bit), version 10.2.0.3 or later.
  • For connections to import data from DB2 databases, IBM OLE DB Provider (32-bit or 64-bit). Whether the driver is 32-bit or 64-bit is determined by the operating system, so that for 64-bit operating systems the 64-bit drivers are required.
  • PowerShell 3.0+.
  • For connection to AWS, you also require AWS Tools for PowerShell version 3.3.283.0 or later.
  • For connection to Microsoft Azure you will require PowerShell version 5.1 or later, as well as the Microsoft Azure Resource Manager module version 6.8.1 or later.
  • For connection to Microsoft Office 365 Online Service, the following are also required: